Remove APM support
[grml-autoconfig.git] / debian / rules
index 82bbdbe..ffbc60b 100755 (executable)
@@ -30,7 +30,7 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs etc/grml etc/init.d usr/sbin usr/bin usr/share/doc/grml-saveconfig usr/lib/grml-autoconfig
+       dh_installdirs etc/grml etc/init.d usr/sbin usr/bin usr/share/doc/grml-saveconfig
 
        # Add here commands to install the package into debian/grml-autoconfig.
        install -m 755 grml-autoconfig      debian/grml-autoconfig/etc/init.d/grml-autoconfig
@@ -41,10 +41,8 @@ install: build
        install -m 755 sbin/grml-autoconfig debian/grml-autoconfig/usr/sbin/grml-autoconfig
        install -m 755 grml-bootsplash      debian/grml-autoconfig/usr/bin/grml-bootsplash
 
-       install -m 755 bin/mkpersistenthome debian/grml-autoconfig/usr/bin/mkpersistenthome
        install -m 755 bin/restore-config debian/grml-autoconfig/usr/bin/restore-config
        install -m 755 bin/save-config debian/grml-autoconfig/usr/bin/save-config
-       install -m 755 lib/pump-runparts debian/grml-autoconfig/usr/lib/grml-autoconfig/pump-runparts
 
        # just as a "backup" solution:
        cp -a etc/* debian/grml-autoconfig/etc/
@@ -59,10 +57,10 @@ binary-indep: build install
        dh_testroot
        dh_installchangelogs
        dh_installdocs doc/grml-autoconfig.1.html doc/grml-autoconfig.8.html \
-                       doc/grml-bootsplash.1.html doc/mkpersistenthome.1.html \
+                       doc/grml-bootsplash.1.html \
                        doc/restore-config.1.html doc/save-config.1.html
        dh_installman doc/grml-autoconfig.1.gz doc/grml-autoconfig.8.gz \
-                       doc/grml-bootsplash.1.gz doc/mkpersistenthome.1.gz \
+                       doc/grml-bootsplash.1.gz \
                        doc/restore-config.1.gz doc/save-config.1.gz
        # backward compability:
        dh_link /usr/share/doc/grml-autoconfig/grml-autoconfig.1.html /usr/share/doc/grml-saveconfig/grml-config.html