Revert "SW: provide xserver-xorg-video-intel on GRML_FULL"
[grml-live.git] / debian / rules
index 0d9a343..329a430 100755 (executable)
 b=$(CURDIR)/debian/build
 VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       grep -q "GRML_LIVE_VERSION=.${VERSION}" grml-live || \
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
                        (echo "Wrong version in grml-live" && exit 2)
        cd docs && $(MAKE) && cd ../
        touch $@
@@ -36,7 +40,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
 grml-live: install
@@ -46,6 +50,7 @@ grml-live: install
        dh_installdocs       -p$@ -P$(b)/$@
        dh_installchangelogs -p$@ -P$(b)/$@
        dh_install           -p$@ -P$(b)/$@
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(VERSION)'/" $(b)/$@/usr/sbin/grml-live
        dh_strip             -p$@ -P$(b)/$@
        dh_compress          -p$@ -P$(b)/$@
        mkdir -p $(b)/$(@)/usr/share/lintian/overrides/