Rework debian/, following current best practices
[grml-live.git] / debian / rules
index 971a44a..8787428 100755 (executable)
@@ -1,72 +1,28 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+include /usr/share/dpkg/pkg-info.mk
 
-build-stamp:
-       dh_testdir
-       cd docs && $(MAKE) && cd ../
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       cd docs && $(MAKE) clean && cd ../
-
-       dh_clean 
+%:
+       dh $@
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
-                      usr/share/grml-live usr/share/grml-live/buildd
+override_dh_binary:
+       dh_binary
 
-       # Add here commands to install the package into debian/grml-live.
-       cp -a etc         debian/grml-live/
-       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
-       cp -a templates   debian/grml-live/usr/share/grml-live/
-       cp -a scripts     debian/grml-live/usr/share/grml-live/
-       cp -a buildd/*.sh debian/grml-live/usr/share/grml-live/buildd/
-       install -o root -m 640 buildd/grml-buildd.conf debian/grml-live/etc/grml/grml-buildd.conf
-       install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+override_dh_install:
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
+                       (echo "Wrong version in grml-live" && exit 2)
+       # build docs
+       cd docs && $(MAKE) && cd ../
+       # adjust version number inside grml-live executable
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(DEB_VERSION)'/" grml-live
+       find . -name grml-live.8
+       dh_install
 
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs docs/grml-live.html
-       dh_installexamples
-       dh_installman docs/grml-live.8
-       dh_link
-       dh_strip
-       dh_compress
-       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
-       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
+override_dh_fixperms:
        dh_fixperms
        # make sure they are executable:
        chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install