Add mbr/ - update --grub handling
[grml2usb.git] / debian / rules
index 2b987f7..0606291 100755 (executable)
@@ -16,6 +16,7 @@ build-stamp:
 
        # Add here commands to compile the package.
        $(MAKE)
+       cd mbr && $(MAKE) && cd ..
        touch build-stamp
 
 clean:
@@ -25,13 +26,14 @@ clean:
 
        # Add here commands to clean up after the build process.
        $(MAKE) clean
+       cd mbr && $(MAKE) clean && cd ..
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs usr/share/grml2usb/lilo usr/share/grml2usb/grub
+       dh_installdirs usr/share/grml2usb/lilo usr/share/grml2usb/grub usr/share/grml2usb/mbr
 
        # Add here commands to install the package into debian/grml2usb.
        install -m 755 grml2usb               debian/grml2usb/usr/sbin/grml2usb
@@ -39,6 +41,7 @@ install: build
        install -m 755 lilo/lilo.static.amd64 debian/grml2usb//usr/share/grml2usb/lilo/lilo.static.amd64
        install -m 644 grub/splash.xpm.gz     debian/grml2usb/usr/share/grml2usb/grub/splash.xpm.gz
        install -m 644 grub/stage2_eltorito   debian/grml2usb/usr/share/grml2usb/grub/stage2_eltorito
+       install -m 644 mbr/mbrmgr             debian/grml2usb/usr/share/grml2usb/mbr/mbrmgr
 
 # Build architecture-dependent files here.
 binary-arch: build install