Improve --vm and --vmfile usage instructions
[grml-debootstrap.git] / debian / rules
index ef04941..9e501f5 100755 (executable)
@@ -9,11 +9,16 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
        (cd tests && ./run_tests.sh)
+       make shellcheck
        make
        touch $@
 
@@ -40,7 +45,7 @@ install: build
        install -m 755 grml-debootstrap debian/grml-debootstrap/usr/sbin/
        install -m 644 zsh-completion   debian/grml-debootstrap/etc/zsh/completion.d/_grml-debootstrap
        install -m 644 cmdlineopts.clp  debian/grml-debootstrap/usr/share/grml-debootstrap/functions/cmdlineopts.clp
-       install -m 644 bootgrub.mksh    debian/grml-debootstrap/usr/share/grml-debootstrap/bootgrub.mksh
+       install -m 755 bootgrub.mksh    debian/grml-debootstrap/usr/share/grml-debootstrap/bootgrub.mksh
 
 # Build architecture-dependent files here.
 binary-arch: build install