Remove mkisofs from Depends:
[grml-live.git] / debian / rules
index 905916b..277a911 100755 (executable)
 #export DH_VERBOSE=1
 
 b=$(CURDIR)/debian/build
+VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
 
 build: build-stamp
 
 build-stamp:
        dh_testdir
+       grep -q "GRML_LIVE_VERSION=.${VERSION}" grml-live || \
+                       (echo "Wrong version in grml-live" && exit 2)
        cd docs && $(MAKE) && cd ../
        touch $@
 
@@ -78,11 +81,51 @@ grml-live-addons: install
        dh_md5sums           -p$@ -P$(b)/$@
        dh_builddeb          -p$@ -P$(b)/$@
 
+grml-live-db: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
+
+grml-live-buildd: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
+
 # Build architecture-dependent files here.
 binary-all: build install
 
 # Build architecture-independent files here.
-binary-indep: build install grml-live grml-live-addons
+binary-indep: build install grml-live grml-live-addons grml-live-db grml-live-buildd
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install