debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-live.git] / debian / rules
index 905916b..329a430 100755 (executable)
 #export DH_VERBOSE=1
 
 b=$(CURDIR)/debian/build
+VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
+                       (echo "Wrong version in grml-live" && exit 2)
        cd docs && $(MAKE) && cd ../
        touch $@
 
@@ -33,7 +40,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
 grml-live: install
@@ -43,6 +50,7 @@ grml-live: install
        dh_installdocs       -p$@ -P$(b)/$@
        dh_installchangelogs -p$@ -P$(b)/$@
        dh_install           -p$@ -P$(b)/$@
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(VERSION)'/" $(b)/$@/usr/sbin/grml-live
        dh_strip             -p$@ -P$(b)/$@
        dh_compress          -p$@ -P$(b)/$@
        mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
@@ -58,7 +66,7 @@ grml-live: install
        dh_md5sums           -p$@ -P$(b)/$@
        dh_builddeb          -p$@ -P$(b)/$@
 
-grml-live-addons: install
+grml-live-db: install
        @echo "--- Building: $@"
        dh_installdirs       -p$@ -P$(b)/$@
        dh_link              -p$@ -P$(b)/$@
@@ -82,7 +90,7 @@ grml-live-addons: install
 binary-all: build install
 
 # Build architecture-independent files here.
-binary-indep: build install grml-live grml-live-addons
+binary-indep: build install grml-live grml-live-db
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install