debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-live.git] / debian / rules
index 971a44a..329a430 100755 (executable)
@@ -9,10 +9,19 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+b=$(CURDIR)/debian/build
+VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
+
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
+                       (echo "Wrong version in grml-live" && exit 2)
        cd docs && $(MAKE) && cd ../
        touch $@
 
@@ -24,49 +33,64 @@ clean:
        # Add here commands to clean up after the build process.
        cd docs && $(MAKE) clean && cd ../
 
-       dh_clean 
+       dh_clean
+       # clean up the stuff dh_clean leaves behind
+       -rm -rf debian/build
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
-                      usr/share/grml-live usr/share/grml-live/buildd
+       dh_prep
+       dh_installdirs
 
-       # Add here commands to install the package into debian/grml-live.
-       cp -a etc         debian/grml-live/
-       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
-       cp -a templates   debian/grml-live/usr/share/grml-live/
-       cp -a scripts     debian/grml-live/usr/share/grml-live/
-       cp -a buildd/*.sh debian/grml-live/usr/share/grml-live/buildd/
-       install -o root -m 640 buildd/grml-buildd.conf debian/grml-live/etc/grml/grml-buildd.conf
-       install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
+grml-live: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(VERSION)'/" $(b)/$@/usr/sbin/grml-live
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       # make sure they are executable:
+       chmod 755 $(b)/$(@)/etc/grml/fai/config/hooks/*
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+grml-live-db: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
 
 # Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs docs/grml-live.html
-       dh_installexamples
-       dh_installman docs/grml-live.8
-       dh_link
-       dh_strip
-       dh_compress
-       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
-       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
-       dh_fixperms
-       # make sure they are executable:
-       chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+binary-all: build install
+
+# Build architecture-independent files here.
+binary-indep: build install grml-live grml-live-db
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install