debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-live.git] / debian / rules
index 9f05b02..329a430 100755 (executable)
@@ -9,50 +9,88 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+b=$(CURDIR)/debian/build
+VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
+
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
+                       (echo "Wrong version in grml-live" && exit 2)
+       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
+
+       # Add here commands to clean up after the build process.
+       cd docs && $(MAKE) clean && cd ../
 
-       dh_clean 
+       dh_clean
+       # clean up the stuff dh_clean leaves behind
+       -rm -rf debian/build
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs usr/sbin
+       dh_prep
+       dh_installdirs
 
-       # Add here commands to install the package into debian/grml-live.
-       install ... debian/grml-live/usr/sbin/
+grml-live: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(VERSION)'/" $(b)/$@/usr/sbin/grml-live
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       # make sure they are executable:
+       chmod 755 $(b)/$(@)/etc/grml/fai/config/hooks/*
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+grml-live-db: install
+       @echo "--- Building: $@"
+       dh_installdirs       -p$@ -P$(b)/$@
+       dh_link              -p$@ -P$(b)/$@
+       dh_installdocs       -p$@ -P$(b)/$@
+       dh_installchangelogs -p$@ -P$(b)/$@
+       dh_install           -p$@ -P$(b)/$@
+       dh_strip             -p$@ -P$(b)/$@
+       dh_compress          -p$@ -P$(b)/$@
+       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
+       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
+       dh_fixperms          -p$@ -P$(b)/$@
+       dh_makeshlibs        -p$@ -P$(b)/$@ -V
+       dh_installdeb        -p$@ -P$(b)/$@
+       dh_shlibdeps         -p$@ -P$(b)/$@
+       dh_installdebconf    -p$@ -P$(b)/$@
+       dh_gencontrol        -p$@ -P$(b)/$@
+       dh_md5sums           -p$@ -P$(b)/$@
+       dh_builddeb          -p$@ -P$(b)/$@
 
 # Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+binary-all: build install
+
+# Build architecture-independent files here.
+binary-indep: build install grml-live grml-live-db
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install