debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-live.git] / debian / rules
index fe5c703..329a430 100755 (executable)
 b=$(CURDIR)/debian/build
 VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       grep -q "GRML_LIVE_VERSION=.${VERSION}" grml-live || \
+       egrep -q "GRML_LIVE_VERSION=.*UNRELEASED" grml-live || \
                        (echo "Wrong version in grml-live" && exit 2)
        cd docs && $(MAKE) && cd ../
        touch $@
@@ -36,7 +40,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
 grml-live: install
@@ -46,6 +50,7 @@ grml-live: install
        dh_installdocs       -p$@ -P$(b)/$@
        dh_installchangelogs -p$@ -P$(b)/$@
        dh_install           -p$@ -P$(b)/$@
+       sed -i -e "s/GRML_LIVE_VERSION='\*\*\*UNRELEASED\*\*\*'/GRML_LIVE_VERSION='$(VERSION)'/" $(b)/$@/usr/sbin/grml-live
        dh_strip             -p$@ -P$(b)/$@
        dh_compress          -p$@ -P$(b)/$@
        mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
@@ -81,31 +86,11 @@ grml-live-db: install
        dh_md5sums           -p$@ -P$(b)/$@
        dh_builddeb          -p$@ -P$(b)/$@
 
-grml-live-buildd: install
-       @echo "--- Building: $@"
-       dh_installdirs       -p$@ -P$(b)/$@
-       dh_link              -p$@ -P$(b)/$@
-       dh_installdocs       -p$@ -P$(b)/$@
-       dh_installchangelogs -p$@ -P$(b)/$@
-       dh_install           -p$@ -P$(b)/$@
-       dh_strip             -p$@ -P$(b)/$@
-       dh_compress          -p$@ -P$(b)/$@
-       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
-       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
-       dh_fixperms          -p$@ -P$(b)/$@
-       dh_makeshlibs        -p$@ -P$(b)/$@ -V
-       dh_installdeb        -p$@ -P$(b)/$@
-       dh_shlibdeps         -p$@ -P$(b)/$@
-       dh_installdebconf    -p$@ -P$(b)/$@
-       dh_gencontrol        -p$@ -P$(b)/$@
-       dh_md5sums           -p$@ -P$(b)/$@
-       dh_builddeb          -p$@ -P$(b)/$@
-
 # Build architecture-dependent files here.
 binary-all: build install
 
 # Build architecture-independent files here.
-binary-indep: build install grml-live grml-live-db grml-live-buildd
+binary-indep: build install grml-live grml-live-db
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install