Include grml-live-remaster; Bump Standard-Version
[grml-live.git] / debian / rules
index e61d7fa..7895772 100755 (executable)
@@ -31,13 +31,17 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
-                      usr/share/grml-live
+                      usr/share/grml-live usr/share/grml-live/buildd usr/sbin
 
        # Add here commands to install the package into debian/grml-live.
        cp -a etc         debian/grml-live/
        cp -a examples    debian/grml-live/usr/share/doc/grml-live/
-       cp -a i386_files debian/grml-live/usr/share/grml-live/
-       cp -a windows     debian/grml-live/usr/share/grml-live/
+       cp -a templates   debian/grml-live/usr/share/grml-live/
+       cp -a scripts     debian/grml-live/usr/share/grml-live/
+       cp -a patches     debian/grml-live/usr/share/grml-live/
+       cp -a buildd/*.sh debian/grml-live/usr/share/grml-live/buildd/
+       cp remaster/grml-live-remaster debian/grml-live/usr/sbin/grml-live-remaster
+       install -o root -m 640 buildd/grml-buildd.conf debian/grml-live/etc/grml/grml-buildd.conf
        install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
 
 # Build architecture-independent files here.
@@ -55,6 +59,8 @@ binary-arch: build install
        dh_link
        dh_strip
        dh_compress
+       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
+       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
        dh_fixperms
        # make sure they are executable:
        chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*