Really add remaster/grml-live-remaster
[grml-live.git] / debian / rules
index 9f05b02..c595514 100755 (executable)
@@ -13,13 +13,16 @@ build: build-stamp
 
 build-stamp:
        dh_testdir
-
+       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
+
+       # Add here commands to clean up after the build process.
+       cd docs && $(MAKE) clean && cd ../
 
        dh_clean 
 
@@ -27,10 +30,19 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
-       dh_installdirs usr/sbin
+       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
+                      usr/share/grml-live usr/share/grml-live/buildd usr/sbin
 
        # Add here commands to install the package into debian/grml-live.
-       install ... debian/grml-live/usr/sbin/
+       cp -a etc         debian/grml-live/
+       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
+       cp -a templates   debian/grml-live/usr/share/grml-live/
+       cp -a scripts     debian/grml-live/usr/share/grml-live/
+       cp -a patches     debian/grml-live/usr/share/grml-live/
+       cp -a buildd/*.sh debian/grml-live/usr/share/grml-live/buildd/
+       install -o root -m 640 buildd/grml-buildd.conf     debian/grml-live/etc/grml/grml-buildd.conf
+       install -o root -m 755 remaster/grml-live-remaster debian/grml-live/usr/sbin/grml-live-remaster
+       install -o root -m 755 grml-live                   debian/grml-live/usr/sbin/grml-live
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -41,13 +53,17 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
-       dh_installdocs
+       dh_installdocs docs/grml-live.html
        dh_installexamples
-       dh_installman
+       dh_installman docs/grml-live.8
        dh_link
        dh_strip
        dh_compress
+       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
+       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
        dh_fixperms
+       # make sure they are executable:
+       chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol