Release new version 0.18.5
[grml2usb.git] / debian / rules
index 01b49f8..f83d809 100755 (executable)
@@ -1,69 +1,24 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
+VERSION:=$(shell dpkg-parsechangelog | awk '/Version: / { print $$2 }')
 
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
+%:
+       dh $@
 
-       touch build-stamp
-
-clean:
+override_dh_auto_build:
        dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
+       egrep -q '^PROG_VERSION = "\*\*\*UNKNOWN\*\*\*"' grml2usb || (echo "PROG_VERSION in grml2usb wrong." && exit 2)
+       $(MAKE) -C mbr
+       $(MAKE)
 
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/grml2usb.
-       install -m 755 grml2usb debian/grml2usb/usr/sbin/
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman grml2usb.8
-       dh_link
-       dh_strip
-       dh_compress
+override_dh_fixperms:
+       chmod 664 ./debian/grml2usb/usr/share/grml2usb/mbr/mbrldr
+       chmod 664 ./debian/grml2usb/usr/share/grml2usb/mbr/mbrmgr
        dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_install:
+       dh_install
+       sed -i -e "s/^PROG_VERSION = \"\*\*\*UNKNOWN\*\*\*\"/PROG_VERSION = \"$(VERSION)\"/" ./debian/grml2usb/usr/sbin/grml2usb