Applied patch from Michael Prokop <mika@grml.org> to update debian/control and debian...
[live-boot-grml.git] / debian / rules
index b827a8f..57f8edb 100755 (executable)
@@ -3,25 +3,17 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
 upstream:
-       # Needs: subversion
-       cd .. && svn co svn://svn.debian.org/debian-live/dists/trunk/live-initramfs || true
-       find . -type d -name .svn | xargs rm -rf
+       cd .. && git clone git://git.debian.org/git/users/daniel/live-initramfs.git || true
+       rm -rf ../live-initramfs/.git
 
 build: build-stamp
 build-stamp:
        dh_testdir
 
        # Building package
-       CFLAGS="$(CFLAGS)" $(MAKE)
+       $(MAKE)
+       cd manpages && make && cd ..
 
        touch build-stamp
 
@@ -32,6 +24,7 @@ clean:
 
        # Cleaning package
        $(MAKE) clean
+       cd manpages && make clean && cd ..
 
        dh_clean
 
@@ -49,16 +42,15 @@ install: build
        rm -f debian/live-initramfs/usr/share/doc/live-initramfs/ChangeLog
        mv debian/live-initramfs/usr/share/doc/live-initramfs/ChangeLog.casper debian/live-initramfs/usr/share/doc/live-initramfs/changelog.casper
 
-binary-indep: build install
-
 binary-arch: build install
+
+binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs docs/ChangeLog
        dh_installdocs
        dh_install
        dh_installinit --no-restart-on-upgrade --no-start -- start 89 0 6 .
-       dh_strip
        dh_compress
        dh_fixperms
        dh_installdeb