Build-Depends-Indep on asciidoc, docbook-xsl and xsltproc
[grml-autoconfig.git] / debian / rules
index 38bd7a3..1c592ca 100755 (executable)
@@ -13,6 +13,7 @@ build: build-stamp
 
 build-stamp: 
        dh_testdir
+       cd doc && $(MAKE) && cd ..
 
        touch build-stamp
 
@@ -28,12 +29,12 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
+       cd doc && $(MAKE) clean && cd ..
        dh_installdirs etc/grml etc/init.d usr/sbin usr/bin
 
        # Add here commands to install the package into debian/grml-autoconfig.
        install -m 755 grml-autoconfig      debian/grml-autoconfig/etc/init.d/grml-autoconfig
        install -m 644 autoconfig           debian/grml-autoconfig/etc/grml/autoconfig
-       install -m 644 autoconfig.small     debian/grml-autoconfig/etc/grml/autoconfig.small
        install -m 755 autoconfig.functions debian/grml-autoconfig/etc/grml/autoconfig.functions
        install -m 644 language-functions   debian/grml-autoconfig/etc/grml/language-functions
        install -m 755 sbin/grml-autoconfig debian/grml-autoconfig/usr/sbin/grml-autoconfig
@@ -41,12 +42,12 @@ install: build
        # just as a "backup" solution:
        cp -a etc/* debian/grml-autoconfig/etc/
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
 # Build architecture-dependent files here.
 binary-arch: build install
+# We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs