Clean out grml-live-compat
[grml-live-grml.git] / debian / rules
index 42951e7..a0ebff3 100755 (executable)
@@ -9,11 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
@@ -21,45 +24,27 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       cd docs && $(MAKE) clean && cd ../
-
-       dh_clean 
+       dh_clean
+       # clean up the stuff dh_clean leaves behind
+       -rm -rf debian/build
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
-                      usr/share/grml-live
-
-       # Add here commands to install the package into debian/grml-live.
-       cp -a etc         debian/grml-live/
-       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
-       cp -a i386_files debian/grml-live/usr/share/grml-live/
-       cp -a windows     debian/grml-live/usr/share/grml-live/
-       install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
+       dh_prep
+       dh_installdirs
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
-       dh_installdocs docs/grml-live.html
-       dh_installexamples
-       dh_installman docs/grml-live.8
+       dh_install
+       dh_installchangelogs
+       dh_installdocs
        dh_link
        dh_strip
        dh_compress
-       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
-       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
        dh_fixperms
-       # make sure they are executable:
-       chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol