Clean out grml-live-compat
[grml-live-grml.git] / debian / rules
index 905916b..a0ebff3 100755 (executable)
@@ -9,13 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-b=$(CURDIR)/debian/build
+build: build-arch build-indep
 
-build: build-stamp
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
@@ -23,9 +24,6 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       cd docs && $(MAKE) clean && cd ../
-
        dh_clean
        # clean up the stuff dh_clean leaves behind
        -rm -rf debian/build
@@ -33,56 +31,25 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
-grml-live: install
-       @echo "--- Building: $@"
-       dh_installdirs       -p$@ -P$(b)/$@
-       dh_link              -p$@ -P$(b)/$@
-       dh_installdocs       -p$@ -P$(b)/$@
-       dh_installchangelogs -p$@ -P$(b)/$@
-       dh_install           -p$@ -P$(b)/$@
-       dh_strip             -p$@ -P$(b)/$@
-       dh_compress          -p$@ -P$(b)/$@
-       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
-       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
-       dh_fixperms          -p$@ -P$(b)/$@
-       # make sure they are executable:
-       chmod 755 $(b)/$(@)/etc/grml/fai/config/hooks/*
-       dh_makeshlibs        -p$@ -P$(b)/$@ -V
-       dh_installdeb        -p$@ -P$(b)/$@
-       dh_shlibdeps         -p$@ -P$(b)/$@
-       dh_installdebconf    -p$@ -P$(b)/$@
-       dh_gencontrol        -p$@ -P$(b)/$@
-       dh_md5sums           -p$@ -P$(b)/$@
-       dh_builddeb          -p$@ -P$(b)/$@
-
-grml-live-addons: install
-       @echo "--- Building: $@"
-       dh_installdirs       -p$@ -P$(b)/$@
-       dh_link              -p$@ -P$(b)/$@
-       dh_installdocs       -p$@ -P$(b)/$@
-       dh_installchangelogs -p$@ -P$(b)/$@
-       dh_install           -p$@ -P$(b)/$@
-       dh_strip             -p$@ -P$(b)/$@
-       dh_compress          -p$@ -P$(b)/$@
-       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
-       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
-       dh_fixperms          -p$@ -P$(b)/$@
-       dh_makeshlibs        -p$@ -P$(b)/$@ -V
-       dh_installdeb        -p$@ -P$(b)/$@
-       dh_shlibdeps         -p$@ -P$(b)/$@
-       dh_installdebconf    -p$@ -P$(b)/$@
-       dh_gencontrol        -p$@ -P$(b)/$@
-       dh_md5sums           -p$@ -P$(b)/$@
-       dh_builddeb          -p$@ -P$(b)/$@
-
-# Build architecture-dependent files here.
-binary-all: build install
-
 # Build architecture-independent files here.
-binary-indep: build install grml-live grml-live-addons
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_install
+       dh_installchangelogs
+       dh_installdocs
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install