grml-live-compat: copy files from Debian packages
[grml-live-grml.git] / debian / rules
index b9633bf..a32c210 100755 (executable)
@@ -9,11 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
@@ -21,46 +24,48 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       cd docs && $(MAKE) clean && cd ../
-
-       dh_clean 
+       dh_clean
+       # clean up the stuff dh_clean leaves behind
+       -rm -rf debian/build
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
-                      usr/share/grml-live usr/share/grml-live/examples
-
-       # Add here commands to install the package into debian/grml-live.
-       cp -a etc         debian/grml-live/
-       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
-       cp -a templates   debian/grml-live/usr/share/grml-live/
-       cp -a buildd/*.sh debian/grml-live/usr/share/grml-live/examples/
-       install -o root -m 640 buildd/grml-buildd.conf debian/grml-live/etc/grml/grml-buildd.conf
-       install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
+       dh_prep
+       dh_installdirs
+       # grub files
+       install -d debian/tmp/templates/compat/grub
+       cp -a /usr/lib/grub/*-pc/*.mod debian/tmp/templates/compat/grub/
+       cp -a /usr/lib/grub/*-pc/*.o debian/tmp/templates/compat/grub/
+       cp -a /usr/lib/grub/*-pc/*.lst debian/tmp/templates/compat/grub/
+       cp -a /usr/share/grub/ascii.pf2 debian/tmp/templates/compat/grub/
+       /usr/bin/grub-mkimage -d /usr/lib/grub/*-pc -o \
+               debian/tmp/templates/compat/grub/core.img biosdisk iso9660 --format=i386-pc
+       # isolinux base files
+       install -d debian/tmp/templates/compat/isolinux
+       for file in isolinux.bin ifcpu64.c32 vesamenu.c32; do \
+               cp -a "/usr/lib/syslinux/$${file}" debian/tmp/templates/compat/isolinux/ ; \
+       done
+       # others
+       install -d debian/tmp/templates/compat/addons
+       cp -a /usr/lib/ipxe/ipxe.lkrn debian/tmp/templates/compat/addons/
+       cp -a /usr/share/misc/pci.ids debian/tmp/templates/compat/addons/
+       cp -a /boot/memtest86+.bin debian/tmp/templates/compat/addons/
+       for file in memdisk chain.c32 hdt.c32 menu.c32; do \
+               cp -a "/usr/lib/syslinux/$${file}" debian/tmp/templates/compat/addons/ ; \
+       done
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
-       dh_installdocs docs/grml-live.html
-       dh_installexamples
-       dh_installman docs/grml-live.8
+       dh_install
+       dh_installchangelogs
+       dh_installdocs TODO
        dh_link
        dh_strip
        dh_compress
-       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
-       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
        dh_fixperms
-       # make sure they are executable:
-       chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol