Drop TODO installation code from debian/rules.
[grml-live-grml.git] / debian / rules
index 905916b..e67a18b 100755 (executable)
@@ -9,13 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-b=$(CURDIR)/debian/build
+build: build-arch build-indep
 
-build: build-stamp
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
-       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
@@ -23,9 +24,6 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       cd docs && $(MAKE) clean && cd ../
-
        dh_clean
        # clean up the stuff dh_clean leaves behind
        -rm -rf debian/build
@@ -33,56 +31,46 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
-
-grml-live: install
-       @echo "--- Building: $@"
-       dh_installdirs       -p$@ -P$(b)/$@
-       dh_link              -p$@ -P$(b)/$@
-       dh_installdocs       -p$@ -P$(b)/$@
-       dh_installchangelogs -p$@ -P$(b)/$@
-       dh_install           -p$@ -P$(b)/$@
-       dh_strip             -p$@ -P$(b)/$@
-       dh_compress          -p$@ -P$(b)/$@
-       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
-       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
-       dh_fixperms          -p$@ -P$(b)/$@
-       # make sure they are executable:
-       chmod 755 $(b)/$(@)/etc/grml/fai/config/hooks/*
-       dh_makeshlibs        -p$@ -P$(b)/$@ -V
-       dh_installdeb        -p$@ -P$(b)/$@
-       dh_shlibdeps         -p$@ -P$(b)/$@
-       dh_installdebconf    -p$@ -P$(b)/$@
-       dh_gencontrol        -p$@ -P$(b)/$@
-       dh_md5sums           -p$@ -P$(b)/$@
-       dh_builddeb          -p$@ -P$(b)/$@
-
-grml-live-addons: install
-       @echo "--- Building: $@"
-       dh_installdirs       -p$@ -P$(b)/$@
-       dh_link              -p$@ -P$(b)/$@
-       dh_installdocs       -p$@ -P$(b)/$@
-       dh_installchangelogs -p$@ -P$(b)/$@
-       dh_install           -p$@ -P$(b)/$@
-       dh_strip             -p$@ -P$(b)/$@
-       dh_compress          -p$@ -P$(b)/$@
-       mkdir -p $(b)/$(@)/usr/share/lintian/overrides/
-       cp -av debian/overrides.$(@) $(b)/$(@)/usr/share/lintian/overrides/$(@)
-       dh_fixperms          -p$@ -P$(b)/$@
-       dh_makeshlibs        -p$@ -P$(b)/$@ -V
-       dh_installdeb        -p$@ -P$(b)/$@
-       dh_shlibdeps         -p$@ -P$(b)/$@
-       dh_installdebconf    -p$@ -P$(b)/$@
-       dh_gencontrol        -p$@ -P$(b)/$@
-       dh_md5sums           -p$@ -P$(b)/$@
-       dh_builddeb          -p$@ -P$(b)/$@
-
-# Build architecture-dependent files here.
-binary-all: build install
+       # grub files
+       install -d debian/tmp/templates/compat/grub
+       cp -a /usr/lib/grub/*-pc/*.mod debian/tmp/templates/compat/grub/
+       cp -a /usr/lib/grub/*-pc/*.o debian/tmp/templates/compat/grub/
+       cp -a /usr/lib/grub/*-pc/*.lst debian/tmp/templates/compat/grub/
+       cp -a /usr/share/grub/ascii.pf2 debian/tmp/templates/compat/grub/
+       /usr/bin/grub-mkimage -d /usr/lib/grub/*-pc -o \
+               debian/tmp/templates/compat/grub/core.img biosdisk iso9660 --format=i386-pc
+       # isolinux base files
+       install -d debian/tmp/templates/compat/isolinux
+       for file in isolinux.bin ifcpu64.c32 vesamenu.c32; do \
+               cp -a "/usr/lib/syslinux/$${file}" debian/tmp/templates/compat/isolinux/ ; \
+       done
+       # others
+       install -d debian/tmp/templates/compat/addons
+       cp -a /usr/lib/ipxe/ipxe.lkrn debian/tmp/templates/compat/addons/
+       cp -a /usr/share/misc/pci.ids debian/tmp/templates/compat/addons/
+       cp -a /boot/memtest86+.bin debian/tmp/templates/compat/addons/
+       for file in memdisk chain.c32 hdt.c32 menu.c32; do \
+               cp -a "/usr/lib/syslinux/$${file}" debian/tmp/templates/compat/addons/ ; \
+       done
 
 # Build architecture-independent files here.
-binary-indep: build install grml-live grml-live-addons
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_install
+       dh_installchangelogs
+       dh_installdocs
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install