Support GRML_NAME, drop character limits, unify files in directory templates
[grml-live.git] / debian / rules
index 86fc4ff..1e411db 100755 (executable)
@@ -34,9 +34,9 @@ install: build
                       usr/share/grml-live
 
        # Add here commands to install the package into debian/grml-live.
-       cp -a etc debian/grml-live/
-       cp -a examples debian/grml-live/usr/share/doc/grml-live/
-       cp -a x86_files debian/grml-live/usr/share/grml-live/
+       cp -a etc         debian/grml-live/
+       cp -a examples    debian/grml-live/usr/share/doc/grml-live/
+       cp -a templates   debian/grml-live/usr/share/grml-live/
        install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
 
 # Build architecture-independent files here.
@@ -54,6 +54,8 @@ binary-arch: build install
        dh_link
        dh_strip
        dh_compress
+       mkdir -p $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/
+       cp -av debian/overrides $(CURDIR)/debian/grml-live/usr/share/lintian/overrides/grml-live
        dh_fixperms
        # make sure they are executable:
        chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*