Update of grml_cd stuff, several new files and features
[grml-live.git] / debian / rules
index 9f05b02..86fc4ff 100755 (executable)
@@ -13,13 +13,16 @@ build: build-stamp
 
 build-stamp:
        dh_testdir
-
+       cd docs && $(MAKE) && cd ../
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
+
+       # Add here commands to clean up after the build process.
+       cd docs && $(MAKE) clean && cd ../
 
        dh_clean 
 
@@ -27,10 +30,14 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
-       dh_installdirs usr/sbin
+       dh_installdirs etc/grml/fai/live-initramfs usr/sbin usr/share/doc/grml-live \
+                      usr/share/grml-live
 
        # Add here commands to install the package into debian/grml-live.
-       install ... debian/grml-live/usr/sbin/
+       cp -a etc debian/grml-live/
+       cp -a examples debian/grml-live/usr/share/doc/grml-live/
+       cp -a x86_files debian/grml-live/usr/share/grml-live/
+       install -o root -m 755 grml-live debian/grml-live/usr/sbin/grml-live
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -41,13 +48,15 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
-       dh_installdocs
+       dh_installdocs docs/grml-live.html
        dh_installexamples
-       dh_installman
+       dh_installman docs/grml-live.8
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
+       # make sure they are executable:
+       chmod 755 debian/grml-live/etc/grml/fai/config/hooks/*
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol