Rework debian/ to follow current best practices
[grml-network.git] / debian / rules
index db8fe62..218df65 100755 (executable)
@@ -1,61 +1,8 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
-
-build-stamp:
-       dh_testdir
-       ( cd docs && $(MAKE) )
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       ( cd docs && $(MAKE) clean )
-       rm -f build-stamp
-       dh_prep
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_prep
-       dh_installdirs usr/sbin etc/grml
-
-       install -m 755 sbin/*        debian/grml-network/usr/sbin/
-       install -m 644 net-functions debian/grml-network/etc/grml/
-       install -m 644 routersetup   debian/grml-network/etc/grml/
-
-       ( cd docs && $(MAKE) install DESTDIR=../debian/grml-network )
-
-# Build architecture-independent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs TODO
-       dh_installexamples
-       dh_installman man/grml-ap.8 man/grml-bridge.8 man/grml-router.8
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@