Fix binary-arch-rules-but-pkg-is-arch-indep in debian/rules.
[grml-network.git] / debian / rules
index 96d6e20..28f5ae0 100755 (executable)
@@ -13,16 +13,14 @@ build: build-stamp
 
 build-stamp:
        dh_testdir
+       ( cd docs && $(MAKE) )
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
+       ( cd docs && $(MAKE) clean )
        rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
        dh_clean 
 
 install: build
@@ -35,12 +33,14 @@ install: build
        install -m 644 net-functions debian/grml-network/etc/grml/
        install -m 644 routersetup   debian/grml-network/etc/grml/
 
+       ( cd docs && $(MAKE) install DESTDIR=../debian/grml-network )
+
 # Build architecture-independent files here.
-binary-indep: build install
+binary-arch: build install
 # We have nothing to do by default.
 
 # Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs