build docs and added them to the .deb
[grml-network.git] / debian / rules
index 176e405..ecc272e 100755 (executable)
@@ -13,11 +13,13 @@ build: build-stamp
 
 build-stamp:
        dh_testdir
+       ( cd docs && $(MAKE) )
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
+       ( cd docs && $(MAKE) clean )
        rm -f build-stamp
        dh_clean 
 
@@ -31,6 +33,8 @@ install: build
        install -m 644 net-functions debian/grml-network/etc/grml/
        install -m 644 routersetup   debian/grml-network/etc/grml/
 
+       ( cd docs && $(MAKE) install DESTDIR=../debian/grml-network )
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.