update changelog
[live-boot-grml.git] / debian / rules
index 910523b..1d71477 100755 (executable)
@@ -1,32 +1,31 @@
 #!/usr/bin/make -f
 
 build:
-       # this is needed because dpatch doesn't do file modes on diffs.
-       chmod a+rx scripts/live-bottom/*
-       chmod a+rx hooks/*
        # regular build.
        dh build
 
 %:
-       dh ${@} --with quilt
+       dh ${@} --parallel
 
 override_dh_auto_install:
        dh_auto_install -- DESTDIR=debian/tmp
 
        # Removing useless files
        rm -f debian/tmp/usr/share/doc/live-boot-grml/COPYING
-       # Some more useless files
-       rm -f debian/tmp/usr/share/initramfs-tools/scripts/live-bottom/12fstab
-       rm -f debian/tmp/usr/share/initramfs-tools/scripts/live-bottom/23networking
-       rm -f debian/tmp/usr/share/initramfs-tools/scripts/live-bottom/24preseed
-       rm -f debian/tmp/usr/share/initramfs-tools/scripts/live-bottom/30accessibility
+       rm -f debian/lib/live/boot/FIXME
 
        # live-boot-initramfs-tools
        mkdir -p debian/live-boot-grml-initramfs-tools/usr/share
        mv debian/tmp/usr/share/initramfs-tools debian/live-boot-grml-initramfs-tools/usr/share
 
+       # this is needed because dpatch doesn't do file modes on diffs
+       # and we can't execute this fix during build stage as new files
+       # might be installed during dh_quilt_patch
+       chmod a+rx debian/live-boot-grml-initramfs-tools/usr/share/initramfs-tools/scripts/*
+       chmod a+rx debian/live-boot-grml-initramfs-tools/usr/share/initramfs-tools/hooks/*
+
 override_dh_builddeb:
-       dh_builddeb -- -Zgzip -z9
+       dh_builddeb -- -Zxz
 
 override_dh_install:
        dh_install --fail-missing