Use quilt instead of dpatch
[live-boot-grml.git] / debian / rules
index 455ed48..6d9ad98 100755 (executable)
@@ -1,7 +1,13 @@
 #!/usr/bin/make -f
 
+build:
+       # this is needed because dpatch doesn't do file modes on diffs.
+       chmod a+rx scripts/live-bottom/*
+       # regular build.
+       dh build
+
 %:
-       dh ${@}
+       dh ${@} --with quilt
 
 override_dh_auto_install:
        dh_auto_install -- DESTDIR=debian/live-boot
@@ -12,6 +18,11 @@ override_dh_auto_install:
        # live-boot-initramfs-tools
        mkdir -p debian/live-boot-initramfs-tools/usr/share
        mv debian/live-boot/usr/share/initramfs-tools debian/live-boot-initramfs-tools/usr/share
+       # Some more useless files
+       rm -f debian/live-boot-initramfs-tools/usr/share/initramfs-tools/scripts/live-bottom/12fstab
+       rm -f debian/live-boot-initramfs-tools/usr/share/initramfs-tools/scripts/live-bottom/23networking
+       rm -f debian/live-boot-initramfs-tools/usr/share/initramfs-tools/scripts/live-bottom/24preseed
+       rm -f debian/live-boot-initramfs-tools/usr/share/initramfs-tools/scripts/live-bottom/30accessibility
 
 override_dh_installinit:
        dh_installinit -p live-boot --no-restart-on-upgrade --no-start --update-rcd-params='start 89 0 6 .'