Release new version 0.108
[grml-debootstrap.git] / debian / rules
index e9aada2..5571e03 100755 (executable)
@@ -1,66 +1,13 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+%:
+       dh $@
 
-build-stamp:
-       dh_testdir
-       (cd tests && ./run_tests.sh)
-       make
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       make clean
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs etc/debootstrap usr/sbin etc/debootstrap/extrapackages etc/zsh/completion.d \
-         usr/share/grml-debootstrap/functions
-
-       # Add here commands to install the package into debian/grml-debootstrap.
-       install -m 644 config           debian/grml-debootstrap/etc/debootstrap/
-       install -m 644 devices.tar.gz   debian/grml-debootstrap/etc/debootstrap/
-       install -m 644 locale.gen       debian/grml-debootstrap/etc/debootstrap/
-       install -m 644 packages         debian/grml-debootstrap/etc/debootstrap/
-       install -m 755 chroot-script    debian/grml-debootstrap/etc/debootstrap/
-       install -m 755 grml-debootstrap debian/grml-debootstrap/usr/sbin/
-       install -m 644 zsh-completion   debian/grml-debootstrap/etc/zsh/completion.d/_grml-debootstrap
-       install -m 644 cmdlineopts.clp  debian/grml-debootstrap/usr/share/grml-debootstrap/functions/cmdlineopts.clp
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs TODO THANKS
-       dh_installman grml-debootstrap.8
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+override_dh_auto_test:
+       make shellcheck
+endif