Fix swap partitions missing from fstab
[grml-udev-config.git] / debian / rules
index 7dd91ab..32bbd33 100755 (executable)
@@ -1,12 +1,6 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 build: build-stamp
@@ -28,6 +22,7 @@ install: build
        dh_installdirs /etc/udev/scripts
 
        install -m 755 scripts/forensic-mark-readonly debian/grml-udev-config/etc/udev/scripts/forensic-mark-readonly
+       install -m 755 scripts/grml-udev-rebuildfstab debian/grml-udev-config/etc/udev/scripts/
 
 # Build architecture-dependent files here.
 binary-arch: install
@@ -43,9 +38,11 @@ binary-indep: install
        dh_installudev --name=grml-forensic     --priority 01
        dh_installudev --name=grml-external     --priority 60
        dh_installudev --name=grml-usbdev       --priority 60
-       dh_installudev --name=grml-blockdevices --priority 60
-       dh_installinit --no-start
-       # --update-rcd-params='start 2 S .'
+       dh_installudev --name=grml-dm                   --priority 89
+       dh_installudev --name=grml-blockdevices --priority 90
+       dh_installinit --no-start --name=grml-udev
+       # do *NOT* automatically install it, see README.Debian
+       # --update-rcd-params='start 03 S .'
        dh_installman
        dh_link
        dh_strip