Force gzip compression for lenny support
authorMichael Prokop <mika@grml.org>
Thu, 18 Jun 2015 11:10:27 +0000 (13:10 +0200)
committerMichael Prokop <mika@grml.org>
Thu, 18 Jun 2015 11:11:53 +0000 (13:11 +0200)
Fixes:

| dpkg-deb: file `grml-debian-keyring_2015.06.18_all.deb' contains ununderstood data member data.tar.xz     , giving up

Thanks: Christoph Berg <myon@debian.org> for the hint

debian/rules

index a90b0bc..51b8f9c 100755 (executable)
@@ -4,5 +4,10 @@
 override_dh_auto_build:
        md5sum -c md5sums.txt
 
+# package should work also on older releases like lenny, which
+# don't have support for xz yet
+override_dh_builddeb:
+       dh_builddeb -- -Zgzip
+
 %:
        dh $@