Switch to debhelper, verify keyring md5sums during build
authorChristian Hofstaedtler <ch@grml.org>
Fri, 14 Oct 2011 00:21:38 +0000 (02:21 +0200)
committerChristian Hofstaedtler <ch@grml.org>
Fri, 14 Oct 2011 00:21:38 +0000 (02:21 +0200)
changelog [deleted file]
debian/compat [new file with mode: 0644]
debian/control
debian/dirs [new file with mode: 0644]
debian/install [new file with mode: 0644]
debian/rules
debian/source/format [new file with mode: 0644]

diff --git a/changelog b/changelog
deleted file mode 100644 (file)
index 0a42d85..0000000
--- a/changelog
+++ /dev/null
@@ -1,5 +0,0 @@
-grml-debian-keyring (2007.06.10) unstable; urgency=low
-
-  * Initial release 
-
- -- Alexander Wirt <formorer@grml.org>  Sun, 10 Jun 2007 09:51:21 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..45a4fb7
--- /dev/null
@@ -0,0 +1 @@
+8
index 6706c26..f991746 100644 (file)
@@ -2,7 +2,8 @@ Source: grml-debian-keyring
 Section: misc
 Priority: optional
 Maintainer: Alexander Wirt <formorer@grml.org>
-Standards-Version: 3.7.2
+Standards-Version: 3.9.2
+Build-Depends: debhelper (>= 8)
 Homepage: http://git.grml.org/?p=grml-debian-keyring.git
 Vcs-git: git://git.grml.org/grml-debian-keyring.git
 Vcs-Browser: http://git.grml.org/?p=grml-debian-keyring.git
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..20e67b9
--- /dev/null
@@ -0,0 +1,2 @@
+usr/share/keyrings
+etc/dpkg/origins
diff --git a/debian/install b/debian/install
new file mode 100644 (file)
index 0000000..724dabd
--- /dev/null
@@ -0,0 +1,2 @@
+keyrings usr/share
+origins etc/dpkg
index b47de64..a90b0bc 100755 (executable)
@@ -1,65 +1,8 @@
 #!/usr/bin/make -f
-# debian/rules file - for debian/keyring
-# Based on sample debian/rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# Copyright 1998-2003 James Troup
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
+# -*- makefile -*-
 
-install_dir=install -d -m 755
-install_file=install -m 644
-install_script=install -m 755
-install_binary=install -m 755 -s
+override_dh_auto_build:
+       md5sum -c md5sums.txt
 
-VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-
-build:
-
-clean:
-       $(checkdir)
-       -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
-       -rm -rf debian/tmp
-
-binary-indep: checkroot
-       $(checkdir)
-       -rm -rf debian/tmp
-       $(install_dir) debian/tmp/DEBIAN/
-       $(install_script) debian/postinst debian/tmp/DEBIAN/
-       $(install_script) debian/prerm debian/tmp/DEBIAN/
-
-       $(install_dir) debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/grml-debian-keyring.gpg debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/grml-debian-removed-keys.gpg debian/tmp/usr/share/keyrings/
-
-       $(install_dir) debian/tmp/usr/share/doc/grml-debian-keyring/
-       $(install_file) debian/changelog debian/tmp/usr/share/doc/grml-debian-keyring/changelog
-       gzip -9 debian/tmp/usr/share/doc/grml-debian-keyring/changelog
-       $(install_file) debian/copyright debian/tmp/usr/share/doc/grml-debian-keyring/
-
-       $(install_dir) debian/tmp/etc/dpkg/origins/
-       $(install_file) origins/Grml debian/tmp/etc/dpkg/origins/
-
-       dpkg-gencontrol -pgrml-debian-keyring -isp
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-binary-arch:
-
-define checkdir
-       test -f keyrings/grml-debian-keyring.gpg
-       test -f keyrings/grml-debian-removed-keys.gpg
-endef
-
-# Below here is fairly generic really
-
-binary:                binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+%:
+       dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644 (file)
index 0000000..89ae9db
--- /dev/null
@@ -0,0 +1 @@
+3.0 (native)