Initial import 2007.06.10
authorAlexander Wirt <formorer@grml.org>
Sun, 10 Jun 2007 08:24:54 +0000 (10:24 +0200)
committerAlexander Wirt <formorer@grml.org>
Sun, 10 Jun 2007 08:24:54 +0000 (10:24 +0200)
changelog [new file with mode: 0644]
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/files [new file with mode: 0644]
debian/postinst [new file with mode: 0644]
debian/prerm [new file with mode: 0644]
debian/rules [new file with mode: 0755]
keyrings/grml-debian-keyring.gpg [new file with mode: 0644]
keyrings/grml-debian-removed-keys.gpg [new file with mode: 0644]
md5sums.txt [new file with mode: 0644]

diff --git a/changelog b/changelog
new file mode 100644 (file)
index 0000000..0a42d85
--- /dev/null
+++ b/changelog
@@ -0,0 +1,5 @@
+grml-debian-keyring (2007.06.10) unstable; urgency=low
+
+  * Initial release 
+
+ -- Alexander Wirt <formorer@grml.org>  Sun, 10 Jun 2007 09:51:21 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..0a34337
--- /dev/null
@@ -0,0 +1,6 @@
+grml-debian-keyring (2007.06.10) grml-testing; urgency=low
+
+  * Initial release
+
+ -- Alexander Wirt <formorer@grml.org>  Sun, 10 Jun 2007 09:52:22 +0200
+
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..6d235c6
--- /dev/null
@@ -0,0 +1,13 @@
+Source:grml-debian-keyring
+Section: misc
+Maintainer: Alexander Wirt <formorer@grml.org>
+Bugs: mailto:formorer@grml.org
+Standards-Version: 3.7.2
+
+Package: grml-debian-keyring
+Priority: important
+Architecture: all
+Depends: gnupg (>= 1.0.6-4)
+Description: GnuPG archive key of the grml.org repository
+ The GRML repository digitally signs its Release files. This package
+ contains the repository key used for that.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..f16ae89
--- /dev/null
@@ -0,0 +1,28 @@
+This is Debian GNU's GnuPG keyrings of archive keys.
+
+This package was originally put together by Michael Vogt
+<mvo@debian.org> and has been adapted to grml.org by 
+Alexander Wirt <formorer@grml.org>. 
+
+The keys in the keyrings don't fall under any copyright.  Everything
+else in the package is covered by the GNU GPL.
+
+Debian support files Copyright (C) 2006 Michael Vogt <mvo@debian.org> 
+based on the debian-keyring package maintained by James Troup 
+
+Debian support files for debian-archive-keyring are free software; you
+can redistribute them and/or modify them under the terms of the GNU
+General Public License as published by the Free Software Foundation;
+either version 2, or (at your option) any later version.
+
+Debian support files for debian-archive-keyring are distributed in the
+hope that they will be useful, but WITHOUT ANY WARRANTY; without even
+the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
+PURPOSE.  See the GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License with
+your Debian system, in /usr/share/common-licenses/GPL, or with the
+Debian GNU debian-archive-keyring source package as the file COPYING.
+If not, write to the Free Software Foundation, Inc., 51 Franklin Street,
+Fifth Floor, Boston, MA 02110-1301 USA.
+
diff --git a/debian/files b/debian/files
new file mode 100644 (file)
index 0000000..aff0160
--- /dev/null
@@ -0,0 +1 @@
+grml-debian-keyring_2007.06.10_all.deb misc important
diff --git a/debian/postinst b/debian/postinst
new file mode 100644 (file)
index 0000000..0cf3538
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ -x /usr/bin/apt-key ]; then
+    /usr/bin/apt-key add /usr/share/keyrings/grml-debian-keyring.gpg
+fi
diff --git a/debian/prerm b/debian/prerm
new file mode 100644 (file)
index 0000000..58d0844
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case "$1" in
+    remove|purge)
+       if [ -x /usr/bin/apt-key ]; then
+               /usr/bin/apt-key del ECDEA787
+       fi
+       ;;
+esac
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..a53dd37
--- /dev/null
@@ -0,0 +1,61 @@
+#!/usr/bin/make -f
+# debian/rules file - for debian/keyring
+# Based on sample debian/rules file - for GNU Hello (1.3).
+# Copyright 1994,1995 by Ian Jackson.
+# Copyright 1998-2003 James Troup
+# I hereby give you perpetual unlimited permission to copy,
+# modify and relicense this file, provided that you do not remove
+# my name from the file itself.  (I assert my moral right of
+# paternity under the Copyright, Designs and Patents Act 1988.)
+# This file may have to be extensively modified
+
+install_dir=install -d -m 755
+install_file=install -m 644
+install_script=install -m 755
+install_binary=install -m 755 -s
+
+VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+
+build:
+
+clean:
+       $(checkdir)
+       -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
+       -rm -rf debian/tmp
+
+binary-indep: checkroot
+       $(checkdir)
+       -rm -rf debian/tmp
+       $(install_dir) debian/tmp/DEBIAN/
+       $(install_script) debian/postinst debian/tmp/DEBIAN/
+       $(install_script) debian/prerm debian/tmp/DEBIAN/
+
+       $(install_dir) debian/tmp/usr/share/keyrings/
+       $(install_file) keyrings/grml-debian-keyring.gpg debian/tmp/usr/share/keyrings/
+       $(install_file) keyrings/grml-debian-removed-keys.gpg debian/tmp/usr/share/keyrings/
+
+       $(install_dir) debian/tmp/usr/share/doc/grml-debian-keyring/
+       $(install_file) debian/changelog debian/tmp/usr/share/doc/grml-debian-keyring/changelog
+       $(install_file) debian/copyright debian/tmp/usr/share/doc/grml-debian-keyring/
+
+       dpkg-gencontrol -pgrml-debian-keyring -isp
+       chown -R root.root debian/tmp
+       chmod -R go=rX debian/tmp
+       dpkg --build debian/tmp ..
+
+binary-arch:
+
+define checkdir
+       test -f keyrings/grml-debian-keyring.gpg
+       test -f keyrings/grml-debian-removed-keys.gpg
+endef
+
+# Below here is fairly generic really
+
+binary:                binary-indep binary-arch
+
+checkroot:
+       $(checkdir)
+       test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot
diff --git a/keyrings/grml-debian-keyring.gpg b/keyrings/grml-debian-keyring.gpg
new file mode 100644 (file)
index 0000000..95e9945
Binary files /dev/null and b/keyrings/grml-debian-keyring.gpg differ
diff --git a/keyrings/grml-debian-removed-keys.gpg b/keyrings/grml-debian-removed-keys.gpg
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/md5sums.txt b/md5sums.txt
new file mode 100644 (file)
index 0000000..04dc613
--- /dev/null
@@ -0,0 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+24c87ef79563fad1f32d7356172ff890  keyrings/grml-debian-keyring.gpg
+d41d8cd98f00b204e9800998ecf8427e  keyrings/grml-debian-removed-keys.gpg
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.6 (GNU/Linux)
+
+iD8DBQFGa7P201u8mbx9AgoRAoNDAJoDiNoi08MX6tb7oVCefT9X8t+3/wCfYTA6
+iIQHDhQf3+cZzYeS76OEmSA=
+=QZ3s
+-----END PGP SIGNATURE-----