debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-desktop.git] / debian / rules
index 3e757bd..0a3a823 100755 (executable)
@@ -9,13 +9,9 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-configure-stamp:
-       dh_testdir
-       touch configure-stamp
-
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp:
        dh_testdir
        touch $@
 
@@ -28,20 +24,20 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs etc/skel
 
        cp -a etc/skel debian/grml-desktop/etc/
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
 # Build architecture-dependent files here.
 binary-arch: build install
+# We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_installman
@@ -54,6 +50,7 @@ binary-arch: build install
        dh_installdeb
        find debian/grml-desktop/etc -type f ! -name \*.xpm ! -name \*.png -print | \
        sed -e 's#^debian/grml-desktop##g' > debian/grml-desktop/DEBIAN/conffiles
+       chmod 0755  debian/grml-desktop/etc/skel/.config/rox.sourceforge.net/MIME-types/image
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums