debian/rules: replace deprecated dh_clean -k with dh_prep
[grml-desktop.git] / debian / rules
index d0f048c..0a3a823 100755 (executable)
@@ -24,7 +24,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs etc/skel
 
        cp -a etc/skel debian/grml-desktop/etc/
@@ -37,7 +37,7 @@ binary-arch: build install
 binary-indep: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_installman
@@ -50,6 +50,7 @@ binary-indep: build install
        dh_installdeb
        find debian/grml-desktop/etc -type f ! -name \*.xpm ! -name \*.png -print | \
        sed -e 's#^debian/grml-desktop##g' > debian/grml-desktop/DEBIAN/conffiles
+       chmod 0755  debian/grml-desktop/etc/skel/.config/rox.sourceforge.net/MIME-types/image
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums