SW: replace fuse with fuse3 master
authorMichael Prokop <mika@grml.org>
Tue, 19 Nov 2019 14:55:05 +0000 (15:55 +0100)
committerMichael Prokop <mika@grml.org>
Tue, 19 Nov 2019 14:55:05 +0000 (15:55 +0100)
sshfs depends on fuse3 and can be installed just fine with it:

| # apt install sshfs fuse3
| [...]
| The following NEW packages will be installed:
|   fuse3 krb5-locales libedit2 libfuse3-3 libglib2.0-0 libglib2.0-data libgssapi-krb5-2 libicu63 libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 libssl1.1 libx11-6 libx11-data libxau6 libxcb1 libxdmcp6 libxext6 libxml2 libxmuu1
|   openssh-client shared-mime-info sshfs xauth xdg-user-dirs
| 0 upgraded, 26 newly installed, 0 to remove and 27 not upgraded.
| Need to get 17.1 MB of archives.
| After this operation, 67.6 MB of additional disk space will be used.
| [..]

While when depending on fuse installation of sshfs fails due to:

| # apt install sshfs fuse
| [...]
| The following packages have unmet dependencies:
|  sshfs : Depends: fuse3 but it is not going to be installed
| E: Unable to correct problems, you have held broken packages.
| # apt install sshfs fuse fuse3
| [...]
| The following packages have unmet dependencies:
|  fuse3 : Breaks: fuse
| E: Unable to correct problems, you have held broken packages.

This is known as
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943896 +
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943875
and is also mentioned/related to
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=927291 +
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939767

If we should ever explicitely need the fuse (v2) package we
can re-evaluate the situation then, but for the time being
switch to fuse3 since it's available as of Debian/buster
and breaking our grml{32,64}-full daily builds.

etc/grml/fai/config/package_config/GRML_FULL

index 8e3166e..8d28d4b 100644 (file)
@@ -205,7 +205,7 @@ wvdial
 
 # network transfers
 ca-certificates
-fuse
+fuse3
 lftp
 nfs-kernel-server
 partimage