Converted package to debhelper 8.
[grml-policyrcd.git] / debian / rules
index 9a59981..cbe925d 100755 (executable)
@@ -1,54 +1,3 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-build:
-
-clean:
-       dh_testdir
-       dh_testroot
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs usr/sbin/ etc
-
-       install -m 755 policy-rc.d      debian/grml-policyrcd/usr/sbin/policy-rc.d
-       install -m 644 policy-rc.d.conf debian/grml-policyrcd/etc/policy-rc.d.conf
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_installman policy-rc.d.8
-       # for backwards compatibility:
-       dh_link /usr/sbin/policy-rc.d /usr/sbin/grml-policy-rc.d
-       dh_link /usr/share/man/man8/policy-rc.d.8.gz /usr/share/man/man8/grml-policy-rc.d.8.gz
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@