Clean up debian/rules
[grml-shlib.git] / debian / rules
index 7270d14..8784422 100755 (executable)
@@ -9,56 +9,32 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp:
        dh_testdir
-
        # Add here commands to compile the package.
-       #$(MAKE)
-       #docbook-to-man debian/sh-lib.sgml > sh-lib.1
-
+       $(MAKE)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
-       #-$(MAKE) clean
+       $(MAKE) clean
 
-       dh_clean 
+       dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
 
        # Add here commands to install the package into debian/sh-lib.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/sh-lib
-       cp sh-lib $(CURDIR)/debian/grml-shlib/etc/grml/
-
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/grml-shlib
 
 # Build architecture-independent files here.
 binary-indep: build install binary-arch
@@ -68,32 +44,15 @@ binary-indep: build install binary-arch
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
-#      dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-#      dh_installman
-#      dh_link etc/grml/sh-lib-1.00 etc/grml/sh-lib
-       dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
-#      dh_installdeb
-#      dh_shlibdeps
+       dh_installdeb
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install