Refresh Debian packaging, switching to minimal dh style
[grml-terminalserver.git] / debian / rules
index adff41d..3eb067e 100755 (executable)
@@ -1,61 +1,10 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+%:
+       dh $@
 
-build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs usr/sbin
-
-       # Add here commands to install the package into debian/grml-terminalserver.
+override_dh_auto_build:
        $(MAKE) install DESTDIR=$(CURDIR)/debian/grml-terminalserver
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_installman debian/grml-terminalserver.8 debian/grml-terminalserver-config.8
-       dh_installexamples create-netboot
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install