Drop all grub- and /linuxrc related stuff
[grml-terminalserver.git] / debian / rules
index 96620f3..adff41d 100755 (executable)
@@ -9,25 +9,9 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
@@ -37,40 +21,36 @@ build-stamp: configure-stamp
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
 
-       dh_clean 
+       dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs usr/sbin
 
        # Add here commands to install the package into debian/grml-terminalserver.
        $(MAKE) install DESTDIR=$(CURDIR)/debian/grml-terminalserver
 
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_installman debian/grml-terminalserver.8 debian/grml-terminalserver-config.8
        dh_installexamples create-netboot
        dh_link
        dh_compress
-       mkdir -p debian/grml-terminalserver/usr/share/lintian/overrides/
-       cp -av debian/overrides debian/grml-terminalserver/usr/share/lintian/overrides/grml-terminalserver
        dh_fixperms
        dh_installdeb
        dh_gencontrol
@@ -78,4 +58,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install