debian: refresh debian packaging to use current best practices
[grml-udev-config.git] / debian / rules
index 7dd91ab..638d628 100755 (executable)
@@ -1,63 +1,17 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# export DH_VERBOSE=1
 
-build: build-stamp
+%:
+       dh $@
 
-build-stamp:
-       dh_testdir
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_prep
-       dh_installdirs /etc/udev/scripts
-
-       install -m 755 scripts/forensic-mark-readonly debian/grml-udev-config/etc/udev/scripts/forensic-mark-readonly
-
-# Build architecture-dependent files here.
-binary-arch: install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
+override_dh_install:
+       dh_install
        dh_installudev --name=grml-forensic     --priority 01
        dh_installudev --name=grml-external     --priority 60
        dh_installudev --name=grml-usbdev       --priority 60
-       dh_installudev --name=grml-blockdevices --priority 60
-       dh_installinit --no-start
-       # --update-rcd-params='start 2 S .'
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       mkdir -p debian/grml-udev-config/usr/share/lintian/overrides/
-       cp -av debian/overrides debian/grml-udev-config/usr/share/lintian/overrides/grml-udev-config
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+       dh_installudev --name=brltty            --priority 85
+       dh_installudev --name=grml-dm           --priority 89
+       dh_installudev --name=grml-blockdevices --priority 90