Update debian/rules (binary-arch/-indep)
[grml-x.git] / debian / rules
index 37d047e..fc8db49 100755 (executable)
@@ -9,28 +9,22 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
+build:
+       make clean
+       make doc
 
-build-stamp: configure-stamp
+build-stamp:
        dh_testdir
-
        # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp html-stamp man-stamp
 
        # Add here commands to clean up after the build process.
+       make clean
        dh_clean
 
 install: build
@@ -38,19 +32,18 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs etc/init.d usr/bin
-       # usr/X11R6/lib/X11/xkb/rules/
 
        # Add here commands to install the package into debian/grml-x.
        install -m 755 grml-x     debian/grml-x/usr/bin/grml-x
        cp -r etc/X11/ debian/grml-x/etc/
        cp -r etc/zsh/ debian/grml-x/etc/
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
 # Build architecture-dependent files here.
 binary-arch: build install
+# We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
@@ -68,4 +61,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install