Use SSL for Homepage + Vcs-Browser headers
[zsh-lovers.git] / debian / rules
index ee2bec1..b423719 100755 (executable)
@@ -1,58 +1,7 @@
 #!/usr/bin/make -f
 
-build: build-stamp
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
 
-build-stamp: 
-       dh_testdir
-
-        # html:
-       asciidoc zsh-lovers.1.txt
-       mv zsh-lovers.1.html zsh-lovers.html
-
-        # manpage:
-       a2x -f manpage zsh-lovers.1.txt
-
-        # pdf:
-       #  notice: you might have to run: ln -s /usr/bin/fop ~/bin/fop.sh
-       #  to work around http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=376523
-       a2x -f pdf zsh-lovers.1.txt
-       mv zsh-lovers.1.pdf zsh-lovers.pdf
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f zsh-lovers.1 zsh-lovers.1.fo zsh-lovers.1.xml zsh-lovers.html zsh-lovers.pdf
-       rm -f build-stamp
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs usr/share/doc/zsh-lovers/zsh_people usr/share/man/man1 usr/share/vim/syntax
-
-       # cp -a zsh_people       debian/zsh-lovers/usr/share/doc/zsh-lovers/
-       install -m 644 zsh.vim debian/zsh-lovers/usr/share/vim/syntax/zsh.vim
-
-binary-indep: build install
-       # We have nothing to do
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman zsh-lovers.1
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@