made packet lintian clean
[grml-crypt.git] / debian / rules
index 82d9305..5f7f822 100755 (executable)
@@ -34,7 +34,7 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       $(MAKE)
        #docbook-to-man debian/grml-terminalserver.sgml > grml-terminalserver.1
 
        touch build-stamp
@@ -45,7 +45,8 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       #$(MAKE) clean
+       $(MAKE) doc
+       $(MAKE) clean
 
        dh_clean 
 
@@ -55,17 +56,12 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/grml-terminalserver.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/grml-terminalserver
-       cp grml-crypt $(CURDIR)/debian/grml-crypt/usr/sbin
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/grml-crypt
+       #cp grml-crypt $(CURDIR)/debian/grml-crypt/usr/sbin
 
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -81,8 +77,8 @@ binary-arch: build install
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
-       dh_installman debian/grml-crypt.8
-       dh_link
+#      dh_installman debian/grml-crypt.8
+#      dh_link
 #      dh_strip
        dh_compress
        dh_fixperms
@@ -95,5 +91,9 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure